Tutoriales

Un error crítico en sudo pone en aventura los sistemas Linux y Unix


ACualquier becario sin privilegios que haya iniciado sesión puede atropellar de un error antiguo en sudo para obtener privilegios de root. Fue calificado como un problema de seguridad importante para Linux y sistemas operativos similares a Unix. El equipo de investigación de Qualys ha descubierto que la vulnerabilidad de desbordamiento de pila en sudo se ha estado escondiendo en a plena pinta durante casi 10 primaveras. El error permite que cualquier usuarios locales para obtener ataque root sin autenticación (no se necesita contraseña de becario). Necesitamos aplicar parches a nuestros sistemas operativos lo ayer posible.

Los administradores del sistema usan el comando sudo para otorgar derechos de becario específicos, como reiniciar Nginx o reiniciar el servidor Apache para fines de suministro del servidor. Las herramientas de automatización de TI como Ansible y otras asimismo usan sudo en gran medida.


Un error crítico en sudo pone en aventura los sistemas Linux y Unix

Tenemos dos vulnerabilidades críticas de sudo:

  1. Se descubrió que Sudo manejaba incorrectamente la memoria al analizar líneas de comando. Un atacante específico posiblemente podría utilizar este problema para obtener ataque no intencionado a la cuenta de administrador. (CVE-2021-3156)
  2. Se descubrió que la utilidad Sudo sudoedit manejaba incorrectamente la demostración de permisos de directorio. Un atacante específico posiblemente podría usar este problema para eludir los permisos de archivos y determinar si un directorio existe o no. (CVE-2021-23239)

CVE-2021-3156: Desbordamiento de búfer basado en montón en Sudo (Baron Samedit)

De la publicación del blog:

Sudo es una poderosa utilidad que se incluye en la mayoría, si no en todos, los sistemas operativos basados ​​en Unix y Linux. Permite a los usuarios ejecutar programas con los privilegios de seguridad de otro becario. La vulnerabilidad en sí misma se ha estado escondiendo a plena pinta durante casi 10 primaveras. Se introdujo en julio de 2011 (commit 8255ed69) y afecta a todas las versiones heredadas de 1.8.2 a 1.8.31p2 y a todas las versiones estables de 1.9.0 a 1.9.5p1 en su configuración predeterminada.

La explotación exitosa de esta vulnerabilidad permite que cualquier becario sin privilegios obtenga privilegios de root en el host inerme. Los investigadores de seguridad de Qualys han podido comprobar de forma independiente la vulnerabilidad y desarrollar múltiples variantes de exploit y obtener privilegios de root completos en Ubuntu 20.04 (Sudo 1.8.31), Debian 10 (Sudo 1.8.27) y Fedora 33 (Sudo 1.9.2) . Todavía es probable que otros sistemas operativos y distribuciones sean explotables.

Mitigación

El problema puede corregirse actualizando su sistema a las siguientes versiones del paquete.

Ubuntu y Debian Linux

Debe aplicar el parche en Ubuntu traducción 16.04 / 18.04 / 20.04 LTS y 20.10 usando el comando apt / apt-get command:
sudo apt update
sudo apt upgrade
## or just install sudo upgrade ##
sudo apt install sudo
sudo --version

Arreglando el desbordamiento de búfer basado en montón en Sudo en el escritorio de Ubuntu Linux

Para la distribución estable de Debian (buster), este problema se ha corregido en la traducción 1.8.27-1 + deb10u3. Por lo tanto, ejecute los comandos anteriores asimismo en Debian.

Arch Linux

Caleta la aplicación de terminal y luego ejecute el próximo comando de pacman:
sudo pacman -Syu

:: Synchronizing package databases...
 core                  134.3 KiB   163 KiB/s 00:01 [#####################] 100%
 extra                1650.4 KiB  2.07 MiB/s 00:01 [#####################] 100%
 community               5.3 MiB  8.55 MiB/s 00:01 [#####################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
 
Packages (17) audit-3.0-1  bpytop-1.0.60-1  ca-certificates-mozilla-3.61-1
              filesystem-2021.01.19-1  gnupg-2.2.27-1  go-2:1.15.7-1
              iptables-1:1.8.7-1  krb5-1.18.3-1  libcap-2.47-1
              libgcrypt-1.9.0-2  libnftnl-1.1.9-1  pam-1.5.1-1
              sqlite-3.34.1-1  sudo-1.9.5.p2-1  tar-1.33-1  tzdata-2021a-1
              zstd-1.4.8-1
 
Total Download Size:   138.39 MiB
Total Installed Size:  604.42 MiB
Net Upgrade Size:       -0.05 MiB
 
:: Proceed with installation? [Y/n]

Red Hat Enterprise Linux 8.x / 7.xy CentOS y Fedora Linux

Escriba el comando dnf o el comando yum para corregir el error en RHEL 7.x / 8.xy Fedora Linux:
sudo dnf update

Suse y OpenSUSE Linux

Las versiones 12.xy 15.x de SUSE Enterprise Linux asimismo se ven afectadas. Por ejemplo, podemos usar el comando zypper:
sudo zypper lp -a | grep -i sudo
sudo zypper up

FreeBSD

No lo he probado, pero necesitas desempolvar el puerto o pkg de FreeBSD ejecutando el próximo comando pkg:
sudo pkg update
sudo pkg upgrade

Updating FreeBSD repository catalogue...
Fetching packagesite.txz: 100%    6 MiB   3.2MB/s    00:02    
Processing entries: 100%
FreeBSD repository update completed. 30177 packages processed.
All repositories are up to date.
[[email protected] ~]# pkg upgrade
Updating FreeBSD repository catalogue...
FreeBSD repository is up to date.
All repositories are up to date.
Checking for upgrades (1 candidates): 100%
Processing candidates (1 candidates): 100%
The following 1 package(s) will be affected (of 0 checked):
 
Installed packages to be UPGRADED:
	sudo: 1.9.5p1 -> 1.9.5p2
 
Number of packages to be upgraded: 1
 
942 KiB to be downloaded.
 
Proceed with this action? [y/N]: y
[1/1] Fetching sudo-1.9.5p2.txz: 100%  942 KiB 964.4kB/s    00:01    
Checking integrity... done (0 conflicting)
[1/1] Upgrading sudo from 1.9.5p1 to 1.9.5p2...
[1/1] Extracting sudo-1.9.5p2: 100%
You may need to manually remove /usr/específico/etc/sudoers if it is no longer needed.

Linux escarpado

Utilice el comando apk para aplicar la modernización sudo:
apk update
apk upgrade

Mac OS

Tenemos que esperar a que Apple publique una modernización.

Resumiendo

Todos estos son viejos errores de búfer desbordados en sudo que cualquier becario específico puede explotar sin una contraseña o autenticación. Por lo tanto, debe aplicar correcciones para deshacerse de un error crítico en sudo. Voy a ver la utilidad doas, que es la predeterminada en OpenBSD. Por supuesto, podemos instalar doas desde puertos en NetBSD o FreeBSD. Todavía hay un puerto para Linux.



Publicaciones relacionadas

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Botón volver arriba