Juegos

Se lanzó el administrador de paquetes APT 2.3.12, ya no le permite romper todo

Después de los problemas encontrados con Linus de Linus Tech Tips que rompieron Pop! _OS durante el cambio a Linux, el administrador de paquetes APT se ha actualizado para evitar problemas futuros.

Cubrimos el problema en nuestro artículo anterior donde System76 quería aplicar su propia solución para evitar que apareciera un cuadro de diálogo que permitiría a los usuarios eliminar paquetes importantes. Al mismo tiempo, System76 también habló con el equipo de APT para obtener una solución oficial, y ahora se ha creado y lanzado uno con APT 2.3.12.

El problema no debería haber surgido a menudo y fue el resultado de la ruptura del paquete Steam con APT mencionando muchas cosas diferentes en la terminal que podrían confundir fácilmente a los usuarios. Para continuar tienes que decir «¡Sí, haz lo que te digo!» aporte. Avanza, lo que probablemente deberías estar haciendo Nunca hacer porque la advertencia estaba allí por una razón: se eliminaron los paquetes esenciales.

Fuente de la imagen: YouTube – oh cielos.

Ahora esa opción se ha eliminado y APT ya no intenta eliminar paquetes críticos o protegidos, por lo que cada problema de dependencia debe resolverse manualmente. Como resultado, su paquete no se instalará, eliminará ni actualizará si entra en conflicto, pero al menos tiene uno real. trabaja Sistema. Todavía se puede sobrescribir, pero lo hace. hábito le dirá explícitamente cómo hacer esto en el mensaje de error para evitar que las personas lo vuelvan a hacer de todos modos.

Aparentemente, Pop! _OS ya está listo para realizar los cambios. Es probable que otras distribuciones que utilicen APT sigan su ejemplo durante sus patrones de actualización regulares.

Artículo tomado de.

Publicaciones relacionadas

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Botón volver arriba